CyHalt?

A catchall for PSoC3 discussions not captured by the other forums.

Moderator: ericb

CyHalt?

Postby Turtle » Thu Oct 31, 2013 7:27 am

Hi,
I have made a custom board with CY8C666AXI-052 (PSoC3) processor.
After only soldering up the processor plus the most needed things, the processor worked just fine.
Then I added some other stuff that also seems to work.

But now sometimes the program goes into CyLib.c into CyHalt with reason 0.
Why does this happen?
I have the watchdog enabled, it also seems to work but can not get the processor
out of CyHalt.

Any thoughts are welcome.
Turtle
Bite-Size Cheese
Bite-Size Cheese
 
Posts: 19
Joined: Mon Apr 21, 2008 6:50 am

Re: CyHalt?

Postby Turtle » Thu Oct 31, 2013 7:31 am

Update:

The problem seems to be related to the Miniprog-3. The processor only halts when
the board is powered externally and the Miniprog-3 is connected.
Turtle
Bite-Size Cheese
Bite-Size Cheese
 
Posts: 19
Joined: Mon Apr 21, 2008 6:50 am

Re: CyHalt?

Postby moxbox » Sun Nov 03, 2013 7:01 am

Turtle,

Sounds to me that the miniprog3 can't supply enough power to your board,
and you are hitting the Low Voltage detect / Watchdog reset.
Try powering the board externally, and you will have to change the PSoCProgrammer
settings from "Power Cycle" to "Reset" during programming.

As always, if that doesn't do the trick we need more info (Schematics, project, etc.)
to help further.

regards,
moxbox
If we knew what we were doing, it wouldn't be called research, would it?
-- Albert Einstein
moxbox
Cheese Cube
Cheese Cube
 
Posts: 41
Joined: Thu Oct 15, 2009 9:59 am
Website: http://www.moxon.com
Location: Portland, OR


Return to “%s” PSoC3 General

Who is online

Users browsing this forum: No registered users and 1 guest