Miniprog3 doesn't appear to be working

This forum focuses on questions and issues with the Cypress PSoC Programmer software and Misc. PSoC Tools

Moderator: ericb

Miniprog3 doesn't appear to be working

Postby cboland » Wed Mar 19, 2014 6:10 am

I have an open ticket with cypress support for this but thought I'd toss this question here too.
I'll try to make this short; I have two PCBs that are working and were taking new downloads from miniprog3 2+ weeks ago. Some time last week I started getting the error like "Can't find silicon" or something similar. By coincidence a new set of PCBs, from another project arrived this week. I took one of the new PCBs, added CY8C3866, caps and 10-pin program port. When I try to program the new PCB I get the same error. In a last ditch effort, I broke out the CY8KIT-001 and tried to program an old Cypress example to the development board. Same problem!
Here's what I know; miniprog3 is able to supply power to PCB (heartbeat LED begins beating on one project board). Status LED is green (and flickers a bit when the program/debug window is open). The "Busy" LED never changes, nor does the "Aux" LED (both always off).
My programming settings are the same as they always were: internal 5.0v, 1.6MH, RESET mode, SWD protocol.
To me, failing to program three separate devices, two known to be working, with the same error, indicates the miniprog3 is at fault.

Occasionally I ran the PCB under its own power (disabling miniprog3's internal 5v supply to PCB) but leave the miniprog3 connected. I have done this for quite some time but am now thinking perhaps the miniprog3 took some kind of power hit that left it in a weird, broken, state.

Has anyone experienced such a miniprog3 fault?
Any other tests I can do to confirm miniprog3 is the bad egg?

Posts: 4
Joined: Tue Jan 21, 2014 3:04 pm

Re: Miniprog3 doesn't appear to be working

Postby bobmarlowe » Thu Mar 20, 2014 4:26 am

I had a similar problem that was caused by an error from updating my Creator-software. Was cured by Cypress with a remote session.
What else comes to my mind is that there were revisions of MiniProg3 that made problems, so better tell Cypress the revision number (Sticker) of your MP.


PS: This forum shuts down within a few days, so better register at if you didn't already.
User avatar
The Big Cheese
The Big Cheese
Posts: 1490
Joined: Thu Oct 06, 2011 2:03 am
Location: Germany

Return to “%s” PSoC Programmer & Misc. Cypress Tools

Who is online

Users browsing this forum: No registered users and 0 guests